Not firing?

Hardware settings, adjustments and fixes and other hardware discussion. This includes the "doHICky" Laser Power measurement system by Russ.
Post Reply
Neil Lawton
Posts: 7
Joined: Sun Jan 12, 2020 7:51 am
Location: York
Country: England
Laser Machine Make or Type: KH5030
Laser Power: 50w
Laser Bed Size: 19 x 12
Home Position: BR
RDWorks Version: v8.01.10
Windows Version: 7
Accessories: rotary axis

My 5030 blue and white 50w laser was fine when last used in April / May. It has an old duvet covering it when not in use and occasionally has stuff from the boot of the car put on it when room is necessary. I went to use it yesterday and everything is working as it should do but no burn! Is it possibly the tube that needs replacing? Any advice would be a help. Neil
Pete Cyr
Posts: 1964
Joined: Sun Nov 27, 2016 5:16 pm
Location: Suffolk Virginia
Country: United States
Laser Machine Make or Type: Boss 1630
Laser Power: 100w
Laser Bed Size: 16"x30"
Home Position: TR
Control Software: RDWORKS
RDWorks Version: v8.01.18
Ruida Controller: RDC6442
Windows Version: Win 10
Accessories: roller rotary attachment

First I would check all the safety switches working and the water flow switch
Location - VA
Equipment - Boss Laser 1630
Power - 100W
Laser Bed Size - 16" x 30"
Home Position - TR
Full RDWorks Version - v8.01.18
First name - Pete
Neil Lawton
Posts: 7
Joined: Sun Jan 12, 2020 7:51 am
Location: York
Country: England
Laser Machine Make or Type: KH5030
Laser Power: 50w
Laser Bed Size: 19 x 12
Home Position: BR
RDWorks Version: v8.01.10
Windows Version: 7
Accessories: rotary axis

Hi Pete.
It doesn't appear to have any interlock switches on this machine. I've flushed out the pump and changed the water and can see it flowing through the tube. Is there a way of metering out the flow sensor to check it actually working?
Post Reply

Return to “General Hardware”